Enable WPA3 on OpenWrt 19.07

Enable WPA3 on OpenWrt 19.07

The latest release of OpenWrt will be fully available on January 12th, 2020. They started the final builds on the fifth. I upgraded one of my Meraki APs with the release candidate earlier because I am excited for WPA3. I just started updating the rest of my APs and wanted to share the process I used to enable WPA3.

The documentation which I saw, tells you to install wpad-openssl for WPA3 support. I found it to be slightly more complicated than that. I saw the error below and I imagine others might too…

root@OpenWrt:~# opkg install wpad-openssl
Installing wpad-openssl (2019-08-08-ca8c2bd2-1) to root...
Collected errors:
 * check_conflicts_for: The following packages conflict with wpad-openssl:
 * check_conflicts_for:   wpad-basic * 
 * opkg_install_cmd: Cannot install package wpad-openssl.

I found the following command worked well for me.

root@OpenWrt:~# opkg update 
root@OpenWrt:~# opkg --force-depends --force-maintainer --force-overwrite install wpad-openssl 

After a reboot I was able to enable WPA3 within the Luci interface.

It doesn’t look like Debian Buster or Fedora 31 supports WPA3 yet, but my Android phone is connected.

One thought on “Enable WPA3 on OpenWrt 19.07

  1. Thank You! It works.
    Unfortunately only my iPadPro (iOS 13.4.1) is able to serve WPA3.
    iPhone5S (iOS 12.4.1) and Ubuntu 18.04LTS only serve “mixed mode WPA2/WPA3 (strong)”.

Leave a Reply

Your email address will not be published. Required fields are marked *