HP iLO Amplifier Pack – Installing VMware Tools

HP iLO Amplifier Pack – Installing VMware Tools

We recently installed the iLO Amplifier Pack at work. HP ships this software as a way to easily manage their servers from a central location. The interface looks nice, however they really lock you out of the virtual machine and limit the command line. This presents a major annoyance because they decided to ship this OVA file without installing VMware tools or open-vm-tools.

I did a little digging around through the Veeam backup and discovered the virtual machine was running Debian 9.5. HP pretty much locks out the Administrator account by not assigning the user a shell and using ForceCommand within the sshd_config configuration.

ForceCommand /opt/wolfram/bin/wcli

I was able to install open-vm-tools by booting into the Debian Live CD and using change root to modify the virtual machine environment. We don’t have DHCP on the server network, so I had to set an IP address and DNS server. Make sure the live environment has access to the network before continuing.

sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt

nano /etc/apt/source.list
apt update
apt install open-vm-tools

I confirmed VMware tools was running after rebooting the machine.

I also discovered a couple other things that I will write another post about some day…

HP – In the meantime, please consider shipping this OVA file with open-vm-tools. It is pretty rare to run into a situation where it is not included.

6/13/19 – As of right now the OVA is running Debian Stretch and the sources.list should look like the one below.

3 thoughts on “HP iLO Amplifier Pack – Installing VMware Tools

  1. This helped me out, I appreciate your post. I recently deployed the AMP pack, and had hit up Google to see what others were doing about the missing tools. I hadn’t even thought of liveboot/chroot, kudos on slick workaround.

  2. Hello, do i need to add something to the sources.list?Mine is empty and if i do apt update after checking some files it shows: E: The repository “‘file:/mnt/ram/swupdate/tmp/packages Release’ does not have a release file. N: Updating from such a repository can’t be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.”

    When i try apt install open-vm-tools it says:
    “Package open-vm-tools is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source.
    E: Package ‘open-vm-tools’ has no installation candidate.”

    Could you please help me?

    Thank you
    Patrick

    1. Hi Patrick,

      I’m sorry for the late reply. I updated the post to include a screenshot of the sources.list file. As long as the virtual machine has an active network then that should work for you.

      Let me know if anything else comes up.

      Thanks,

      Joe

Leave a Reply

Your email address will not be published. Required fields are marked *